Jeep Wagoneer Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter · #1 ·
Has anyone else had an issue with the Uconnect software not updating? Every time I turn off the vehicle I get a message that there is a software update available. I press "Update Now" and nothing happens. Just had it in the dealership yesterday too. They updated the firmware for the seat controls, but this issue still persists.
Netbook Output device Plant Communication Device Personal computer
 

·
Registered
Joined
·
19 Posts
Grand Wagoneer SIII picked up 3 weeks ago. I’m 1300 miles in on a short road trip and have already had several UConnect issues. My front screen never has been able to show rear screens or play sound over speakers. On the trip infrequently get a message Airbag system needs service although I am in the mountains and I suspect this is from dropping cellular signal. I intermittently can see the map on the driver’s display. The seat release on the rear second row (to enter third row) sometimes becomes unresponsive and requires shutting off car and walking away to reset. Also side mirrors sometimes don’t always close when vehicle is locked and frequently don’t open back up when vehicle started. In addition lots of other UConnect glitches like screens resetting after I customize settings, improper dimming, losing CarPlay. And don’t even get me started on how unresponsive the heated/ventilated seats buttons are along the center screen. I too am hoping for major improvements from a UConnect update but I’m not sure how many of these “annoying” glitches I should expect to have resolved. Reading these forums and all the issues people are having with drivetrain is giving me anxiety to the point where I’m afraid to even put my vehicle in four wheel drive.
 

·
Registered
Joined
·
3 Posts
Grand Wagoneer SIII picked up 3 weeks ago. I’m 1300 miles in on a short road trip and have already had several UConnect issues. My front screen never has been able to show rear screens or play sound over speakers. On the trip infrequently get a message Airbag system needs service although I am in the mountains and I suspect this is from dropping cellular signal. I intermittently can see the map on the driver’s display. The seat release on the rear second row (to enter third row) sometimes becomes unresponsive and requires shutting off car and walking away to reset. Also side mirrors sometimes don’t always close when vehicle is locked and frequently don’t open back up when vehicle started. In addition lots of other UConnect glitches like screens resetting after I customize settings, improper dimming, losing CarPlay. And don’t even get me started on how unresponsive the heated/ventilated seats buttons are along the center screen. I too am hoping for major improvements from a UConnect update but I’m not sure how many of these “annoying” glitches I should expect to have resolved. Reading these forums and all the issues people are having with drivetrain is giving me anxiety to the point where I’m afraid to even put my vehicle in four wheel drive.
HAVING major issues just like you. At what point are these $ 90,000 trucks Lemons ?
 

·
Registered
Joined
·
12 Posts
Same issue here. Surround Sound option is gone. This seemed to coincide with the latest "D" update that my GW downloaded while at the dealer. I tried resetting the radio but it did not help. The update did not correct CarPlay issues either so now I'm losing features lol
 
1 - 7 of 7 Posts
Top