Jeep Wagoneer Forum banner
81 - 100 of 108 Posts

·
Registered
Joined
·
2 Posts
I got my wagoneer series 3 less than a week ago and I am not able to connect to the vehicle hotspot; connect the car to my phone hotspot; play anything on the front screen; listen to the rear screens through the car speakers; get the stuff playing on one screen to play on the other two. Have eveyones issues been resolved and I just don’t know what I’m doing? Also, what is the point of having rear screens that can only play stuff with wifi. I live where any long trip is through the mountains. I thought I could download something to my phone and then mirror it to the three screens.
 

·
Registered
Joined
·
24 Posts
The Chrysler Pacifica has quite the negative history with the rear uConnect as well dating back to 2017. Over some years many problems seem to have fixes but others seem to still exist. Hardware and software. I wish I knew about the uConnect history with the Pacifica.
 

·
Registered
Joined
·
78 Posts
Its well past June @WagoneerCxSvc and no June update has come - I have an August appt with another dealer on another problem with running boards but assuming that there is no info on the magic June update to fix rear entertainment,
Hi Moosen,

I see Sarah reached back with you requesting a couple of details to help address your concerns. We'd be happy to pick things back up there at your convenience.

Steph
Wagoneer Client Services
 

·
Registered
Joined
·
1 Posts
I’ve got mine set to automatically update software over wifi. I’ll have to check and see what software version we’re currently running. I took some pictures what we’re seeing on both the front radio screen and the passenger display. When we click “Launch Source” it will show the “Fire TV” as a source, but when we click on that we are getting this message:

View attachment 1304

View attachment 1305
I know this post is old but, did you ever get this resolved?
Just purchased mine a week ago and got this message two days later.
 

·
Registered
Joined
·
1 Posts
Hi, catching up on this thread. Purchased a new Grand Wagoneer Series II 10 days ago and no longer have audio (USB, Bluetooth, AirPlay). Have any of the issues been resolved or do I need to reach out to the dealership?

Thanks in advance for any help.
 

·
Registered
Joined
·
78 Posts
Hi @Dionne @Wagoneermis @eckwolfpack

I'm sorry to hear of your concerns. We would like to learn more details and take a look into this for you. Shoot us a PM with your VIN, current SW level, and any additional details about your vehicle to get started.

Steph
Wagoneer Client Services
 

·
Registered
Joined
·
24 Posts
I know this post is old but, did you ever get this resolved?
Just purchased mine a week ago and got this message two days later.
Nope nearly a year later and still doesn't work for me. I’ve got another hail Mary dealer appt at a different dealer to try to fix again.

Jeep delivered a turd of an entertainment package on this. They weren’t mature enough technically to be launching a product like this.
 

·
Registered
Joined
·
24 Posts
No update from me - yet another Wagoneer concierge communicated with me after an attempt to update software told me I’d need to talk to a Star master tech… I’ve done that once (vis dealer) and got nowhere. I need to make another appt at dealer and try again but getting tired of running around on this.
 

·
Registered
Joined
·
78 Posts
Same issues over here. Any updates or fixes? Im
Getting so frustrated with these ongoing issues with a car of this price.
No update from me - yet another Wagoneer concierge communicated with me after an attempt to update software told me I’d need to talk to a Star master tech… I’ve done that once (vis dealer) and got nowhere. I need to make another appt at dealer and try again but getting tired of running around on this.
Hi Kirsty, I received your message, located your current case, and notified your specialist about your concerns! I'll follow up once we receive the requested information from there.

Hi Matt, I was able to update your case as well for further review by your specialist. It looks like a couple of updates have been released since your case opened, which may help with your concerns once your appointment is set at the dealership.

Steph
Wagoneer Client Services
 

·
Registered
Joined
·
1 Posts
Similar issue on our Wagoneer with rear seat audio. (can’t speak to the Usb issues.) The rear screen mirroring worked sporadically when we picked up the vehicle a few weeks ago. But half the time the “Rear Seat” option would be simply absent from the source list. After trying a number of things unsuccessfully - including taking back to the dealer and having them look at it - I tried a factory reset to the Uconnect system. Now, although the Fire Tv screens in the back continue to work well, the center console and front passenger displays show only “This service is not currently available on the front seat displays” instead of mirroring the screens AND cannot stream the audio over the vehicle speakers - AND the Rear Seat audio source option continues to only display sporadically.

Quite embarrassing, I bought this expensive vehicle and system to help my wife with the stress of young children. Instead it’s only added to her frustrations.

Am I missing something here? Any help is appreciated!

Kirk

We are running into several issues with our rear entertainment system on our Wagoneer Series III. I summarized the major things below. I was wondering if anyone else has run into these issues and if they have resolved them in some way.

1. No Sound for Rear Entertainment Screens -- We are not able to get the sound to play through the car speakers for the content playing on the rear entertainment screens. We click 'Listen' on the Media screen for rear entertainment, but no sound. I have also gone into sources and selected listen to the rear screen 1 or 2. Only way to get sound is plug in headphones.

2. USB video content only recognized on one screen -- I plugged in a usb flash drive to the 'rear' usb. The content/videos recognize on the passenger rear screen, but not on the driver side rear screen. Same flash drive worked in our 2019 Pacifica. Also when trying to mirror it says device not capable of mirroring to both screens.

Thanks!
 

·
Registered
Joined
·
78 Posts
Similar issue on our Wagoneer with rear seat audio. (can’t speak to the Usb issues.) The rear screen mirroring worked sporadically when we picked up the vehicle a few weeks ago. But half the time the “Rear Seat” option would be simply absent from the source list. After trying a number of things unsuccessfully - including taking back to the dealer and having them look at it - I tried a factory reset to the Uconnect system. Now, although the Fire Tv screens in the back continue to work well, the center console and front passenger displays show only “This service is not currently available on the front seat displays” instead of mirroring the screens AND cannot stream the audio over the vehicle speakers - AND the Rear Seat audio source option continues to only display sporadically.

Quite embarrassing, I bought this expensive vehicle and system to help my wife with the stress of young children. Instead it’s only added to her frustrations.

Am I missing something here? Any help is appreciated!

Kirk
We're more than happy to have a look into this for you, Kirk. Feel welcome to send us a PM with your VIN to get started.

Steph
Wagoneer Client Services
 

·
Registered
Joined
·
3 Posts
Same issues here in our ‘22 series 3. Cannot control rear screens from the front. Cannot play audio from rear screens over the speakers. Passenger screen is pretty useless due to this. For small kids that need parents to help, this is ridiculous, especially given the price. We have to stop the vehicle and get out to help our kids in the back.
 

·
Registered
Joined
·
1 Posts
I just purchased a 2022 Series I with rear entertainment and passenger screens. Like others on this forum, I am unable to listen to audio from either rear screen source on the whole car audio system. I can control the rears screens from the front most of the time, but I cannot view the source on the primary front and center uconnect screen (when driving or parked).

it seems like some have had success following a firmware update. I have no update available for my VIN I check online. I did enable over the air updates and have my car connected to my home WiFi.

Any suggestions?
 

·
Registered
Joined
·
3 Posts
I just purchased a 2022 Series I with rear entertainment and passenger screens. Like others on this forum, I am unable to listen to audio from either rear screen source on the whole car audio system. I can control the rears screens from the front most of the time, but I cannot view the source on the primary front and center uconnect screen (when driving or parked).

it seems like some have had success following a firmware update. I have no update available for my VIN I check online. I did enable over the air updates and have my car connected to my home WiFi.

Any suggestions?
Ours is now in the shop. Today is the fourth day without the car. We have no idea how long they’ll have it.
 

·
Registered
Joined
·
78 Posts
I just purchased a 2022 Series I with rear entertainment and passenger screens. Like others on this forum, I am unable to listen to audio from either rear screen source on the whole car audio system. I can control the rears screens from the front most of the time, but I cannot view the source on the primary front and center uconnect screen (when driving or parked).

it seems like some have had success following a firmware update. I have no update available for my VIN I check online. I did enable over the air updates and have my car connected to my home WiFi.

Any suggestions?
Hi cburk1, I received your message and will certainly follow up with you from there.

Steph
Wagoneer Client Services
 
81 - 100 of 108 Posts
Top