Jeep Wagoneer Forum banner
21 - 40 of 81 Posts

·
Registered
Joined
·
4 Posts
That is exactly what I am seeing on mine too. I’ve never been able to see the rear screens on the main screen even from day 1.
Dang it I wonder what the problem is. Some guy on a fb forum showed me his main screen works, he just can't select netflix. I'm able to select a USB, Firestick title from the mainscreen and it sends it to the rear screen which will play, but the main screen stays grey.. I hope there's a solution
 

·
Registered
Joined
·
19 Posts
Yesterday evening my GWIII initiated software update at a stop on my way to work. The update went through cellular signal and not when attached to my home Wi-Fi even though I have had this option on for weeks. I sat in a Walgreens parking lot afraid that if I drove it would mess the update up (plus the screen tells you not to drive during update). Following update software version is now S21D.5. Whole update only took about 10 minutes and I have no idea what triggered it because I have scan for updates many times before without anything happening. Following update I tried to run through functions and see if any changes. Still can not view rear entertainment on center screen. Also my surround sound option which had been present is now missing. Perhaps there is a little less freezing and lagging then before. Also in the few days before update my center screen was not turning off when I turned off car or even after I exit vehicle. I would watch screen through window and it seemed to shut down a minute or two after getting out but didn’t seem normal and I was definitely concerned battery might be dead after work. That behavior has resolved after the UConnect update. Anyone else have a different experience or software version?
 

·
Registered
Joined
·
5 Posts
I’ve got mine set to automatically update software over wifi. I’ll have to check and see what software version we’re currently running. I took some pictures what we’re seeing on both the front radio screen and the passenger display. When we click “Launch Source” it will show the “Fire TV” as a source, but when we click on that we are getting this message:

View attachment 1304

View attachment 1305
I am having the same issues. Any luck on a solution?
 

·
Registered
Joined
·
4 Posts
Do you know if the updates are automatic or do I need to initiate the update? Thanks for your reply
I have no idea, I don't even know how to initiate it. All the lady told me was, it doesnt require a dealer visit, it will be sent to the car. I'm guess it will be a pop up and you can download it? I know they removed the Theater app, then it came back, but viewing still didn't work. Only worked on the front passenger display
 

·
Registered
Joined
·
1 Posts
I have no idea, I don't even know how to initiate it. All the lady told me was, it doesnt require a dealer visit, it will be sent to the car. I'm guess it will be a pop up and you can download it? I know they removed the Theater app, then it came back, but viewing still didn't work. Only worked on the front passenger display
Does anyone have a fix for this issue yet?
 

·
Registered
Joined
·
4 Posts
We are running into several issues with our rear entertainment system on our Wagoneer Series III. I summarized the major things below. I was wondering if anyone else has run into these issues and if they have resolved them in some way.

1. No Sound for Rear Entertainment Screens -- We are not able to get the sound to play through the car speakers for the content playing on the rear entertainment screens. We click 'Listen' on the Media screen for rear entertainment, but no sound. I have also gone into sources and selected listen to the rear screen 1 or 2. Only way to get sound is plug in headphones.

2. USB video content only recognized on one screen -- I plugged in a usb flash drive to the 'rear' usb. The content/videos recognize on the passenger rear screen, but not on the driver side rear screen. Same flash drive worked in our 2019 Pacifica. Also when trying to mirror it says device not capable of mirroring to both screens.

Thanks!
Same issues here!!!! I hope someone can help. Trying to decide if I am going to return.
 

·
Registered
Joined
·
1 Posts
I just found this thread when trying to find a solution for the same issue. Has there been any resolution? We can’t get the rear seat entertainment to play through anything but headphones.

When I click “Listen” from the front radio screen or the front passenger screen, nothing happens. I can turn the rear screens on and off from the front, but can’t see any of the content on either of the front screens; just a blank gray screen.

It’s very frustrating because we bought the front passenger display and rear seat entertainment to make it seamless for the co-pilot to control shows for the kids in the back on road trips but at this point none of that is functional.
EXACTLY the same issues for us! Exactly.
 

·
Registered
Joined
·
12 Posts
I am having these same issues on my new GW Series 3...

1) No sound from the rear screens, except headphones.

2) No ability to mirror rear screens to passenger screen. Same message as above, "The service is not currently available..."

Basically, the passenger can't do anything but listen to AM/FM radio. SiriusXM does not work, Bluetooth audio does not work, FireTV does not work.
 

·
Registered
Joined
·
12 Posts
Just bought our Grand Wagoneer 2days ago.

I turned surround sound on and went back through the settings and the surround sound option was gone.

Any update if you figured that out?
Try the Reset Radio option...push and hold both the volume and tuning knobs for 15 seconds. The radio will reset. This helped restore my partial Carplay options.
 

·
Registered
Joined
·
2 Posts
I’ve got mine set to automatically update software over wifi. I’ll have to check and see what software version we’re currently running. I took some pictures what we’re seeing on both the front radio screen and the passenger display. When we click “Launch Source” it will show the “Fire TV” as a source, but when we click on that we are getting this message:

View attachment 1304

View attachment 1305
 

Attachments

·
Registered
Joined
·
2 Posts
Same issues here very disappointed ☹ I will return this car cuz what’s the point of buying it for …. I just want my kids have a better trip with this but nothing happens….
 

·
Registered
Joined
·
3 Posts
Hi, Any solution for rear entertainment audio thru car speakers? I
We'd like to offer our team's support alongside your dealer visit to ensure you're properly taken care of. Please feel free to send us a private message with your VIN and additional details, if you're interested.

Thanks,

Courtney
WagoneerCxSvc
I am having the same issues on mine, is there a fix for this yet? just bought this thing on 2 April 2022. Guess i should have done more research before purchasing, probably would have waited.
 

·
Registered
Joined
·
3 Posts
I am having the same issue as you are. I factory reset everything and it seems to have caused a worse problem. Now the passenger screen will turn on but you cant turn it off with any of the buttons, I have to shut the car down and restart it.
 

·
Registered
Joined
·
33 Posts
Hi everyone,
Feel free to send us a PM with your VIN and additional details if you'd like an extra layer of support alongside your dealer in getting this resolved.

Sarah
WagoneerCxSvc
 

·
Registered
Joined
·
12 Posts
Same issues here very disappointed ☹ I will return this car cuz what’s the point of buying it for …. I just want my kids have a better trip with this but nothing happens….
The Rear Screens need to be connected to a wireless hotspot before they can use NetFlix, Amazon Prime etc., on the rear screens. This can be the Personal Hotspot on your cellphone or the vehicle paid subscription hotspot. My screens do NOT automatically connect to my hotspot. I have to disable it on my iPhone and then enable it again before the screens will connect. Afterwards, everything works. You can check your Network settings and confirm that you are connected.
 

·
Registered
Joined
·
12 Posts
That is exactly what I am seeing on mine too. I’ve never been able to see the rear screens on the main screen even from day 1.
I don't think that this feature is supported yet. I just downloaded the the latest UConnect update (FCA-MY22.S21D.5-PROD and I still get the same "Service Not Available" message. Hopefully it will be implemented soon...
 

·
Registered
Joined
·
3 Posts
I don't think that this feature is supported yet. I just downloaded the the latest UConnect update (FCA-MY22.S21D.5-PROD and I still get the same "Service Not Available" message. Hopefully it will be implemented soon...
They are advertising that it is installed in these. If it wasn’t possible, I wouldn’t have bought the one with the screen up front. I hope this isn’t the case, cause Jeep is gonna see my bad side if I was straight up lied to.
 
21 - 40 of 81 Posts
Top