Jeep Wagoneer Forum banner
1 - 13 of 13 Posts

· Premium Member
Joined
·
12 Posts
Discussion Starter · #1 ·
I wanted to check and see if any of you guys are having similar issues. This is happening 3 to 4 times a week. The lower screen and screen in between back seat passengers randomly goes from 1 to max on air and back to off again. Of course the dealership can’t get it to duplicate when they have it in the shop. I have a video but do not see I can upload videos.
 

· Registered
Joined
·
1 Posts
Having the same issue here. I believe that the touch screen (lower one between the front seats) is having hardware issues. If we raise that screen up and keep it off, no issues happen. But if the screen is down it seems to get phantom presses.

Gonna have to schedule an appt with the dealer for this. Anyone else have this issue?
 

· Registered
Joined
·
1 Posts
Same thing is happening with my GW Series 3. I took it in for the latest software update which resolved the seat warning issue in the back, along with the flashing odometer. I haven't seen this happen since, however, mine has been at the dealership for the last 2 weeks for a screen issue.
 

· Premium Member
Joined
·
12 Posts
Discussion Starter · #4 ·
I just got mine back. My dealership worked with the software engineers and found a part failing that caused “ghost prints” which was causing my screen glitches. They ordered the part and will replace it when it comes in. I will update you guys with exact terminology when I get the print out.
 

· Premium Member
Joined
·
12 Posts
Discussion Starter · #5 ·
Same thing is happening with my GW Series 3. I took it in for the latest software update which resolved the seat warning issue in the back, along with the flashing odometer. I haven't seen this happen since, however, mine has been at the dealership for the last 2 weeks for a screen issue.
What screen issues are you having?
 

· Registered
Joined
·
2 Posts
We are having the same ghost screen glitches. This thing is super buggy... we are hoping Jeep gets the technology issues sorted out soon. There seems to be a new glitch every trip. It's impossible to use Google maps via Andriod Auto on road trips. Very inconvenient to say the least. What did the dealer do to resolve?
 

· Premium Member
Joined
·
12 Posts
Discussion Starter · #7 ·
We are having the same ghost screen glitches. This thing is super buggy... we are hoping Jeep gets the technology issues sorted out soon. There seems to be a new glitch every trip. It's impossible to use Google maps via Andriod Auto on road trips. Very inconvenient to say the least. What did the dealer do to resolve?
They told me the part is due in July 10th. They are going to replace the part and hope that fixes the issue. I will update you when it is replaced.
 

· Registered
Joined
·
2 Posts
Our dealer just rebooted the system and is telling me that is fixing the problem however I am unsure that it really is going to work this time. Curious to know if they changed a piece of hardware or it was all software?
 

· Premium Member
Joined
·
12 Posts
Discussion Starter · #9 ·
Ok, so I dropped my car off last week for them to replace “the part” they deemed that was causing the screen issue. Within an hour they called me to tell me the part arrived damaged and they would need to reorder the part. When I got there to get my car they showed me the damaged part. The “part” is a brand new screen. I do not know if this helps at all. I am spending alot of time tracking my issues. 😕
 

· Registered
Joined
·
2 Posts
Ok, so I dropped my car off last week for them to replace “the part” they deemed that was causing the screen issue. Within an hour they called me to tell me the part arrived damaged and they would need to reorder the part. When I got there to get my car they showed me the damaged part. The “part” is a brand new screen. I do not know if this helps at all. I am spending alot of time tracking my issues. 😕
Hello, did they replace the entire unit? Or is a screen actually available for this system? I'd assume it's the entire unit. My wife recently bought a used GW Series 2, the only issue the vehicle had was a small chip in the infotainment screen. We were OK with this cosmetic issue as long as the system worked OK. Long story short the dealer (Jeff Wyler near Columbus, OH) never mentioned that the screen was having any issues. I drove the vehicle home four hours and didn't have any issues. My wife drove it for a week or two before the screen started ghost pressing in the "climate" area of the screen. Turning the A/C off and on, turning the fan speed down, etc.

We took it to our local Jeep dealership (Twin City in Lafayette, IN) and they determined that Chrysler will not honor the warranty due to the chip in the screen. I truly don't think the chip has anything to do with the ghost pressing. It's in an entirely different area of the screen and the screen worked perfectly for two weeks before problems began. So it looks like we may be out of luck and need to replace the whole unit. I may also try filling in the chip myself and see if that makes any difference at all. Chrysler won't accept it as a core due to the chip anyway so I might as well try to fix it first.
 

· Registered
Joined
·
2 Posts
Freshly released TSB 08-090-22 addresses the wonky touch screens, by updating two modules (one front & one rear).
Do you have a link to this TSB? I did a quick google search but didn't see anything.
Interestingly, the infotainment screen in my wife's GW has stopped ghost pressing now that the weather has gotten colder. It hasn't done it for probably 5 or 6 weeks now.
 
1 - 13 of 13 Posts
Top