Jeep Wagoneer Forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hello,

I plan on taking a road trip in the coming weeks and hooked up a mini DVD player through the HDMI port to play some of the kids favorite movies. A couple issues:

when I hook it up to one of the TVs everything works fine. As soon as I screen mirror on the other screen the video shrinks to half the size and then I get the green “fuzzy” ends around the video.

other issue is I can find a way to play the video sound through the speakers. I push listen on the main dash and I get zero sound.

Any ideas on how to resolve?

thanks
 

·
Registered
Joined
·
19 Posts
Just spent about 2 hours going from front passenger seat to rear seat trying to get the system up and running. I believe I have the most up to date software (the one where you lose surround sound settings). I too have never been able to get sound to play over the cars speakers (except using the hack someone else discovered which I’ll mention later.). The rear screens work reasonably well with built in fire stick and headphones. The front passenger screen will display video from rear screens and can listen over headphones. I also tried every variation of the “listen” button on the main screen and never can hear anything. Closest I’ve come is the sound cutting out from the radio. Controlling anything from passenger screen is very buggy and almost not worth it. I tried a hack someone else on the forum suggested and hooked up a fire stick through the front HDMI port. I then created a Bluetooth connection with the car and could play the sound from the passenger screen movie over the speakers but I could not figure out how to send that video to the rear seats. As I sit hear typing this I do believe I saw an HDMI 1 option on the rear seats and maybe that would have worked. Does anyone know if HDMI 1 is the HDMI under the center counsel? Either way there were wires all in the center tray area and this is not the functionality I thought we were getting. I’ve never had the ability to play video in the center screen even from day one and sadly I just got mine back from dealership today for other repairs and I didn’t even want them to address the rear entertainment problems because I’ve read horror stories on this thread of people who take their vehicles in for that and they swap out head units and everything else and keep the vehicle for weeks. I’m holding out for the promised software update and hoping the rear entertainment issues are fixed with that. Wagoneer Clients services if your listening, any updates?
 

·
Registered
Joined
·
18 Posts
I'm afraid to even try any of the screens, about half of all of the electronics i have tried so far do not work, like the auto park, the voice commands do not work, seat heat and massage goes off after 10 min and have to be turned back on again, the rear screens do come on when ever they want and are just about impossible to turn off, i have never even turned them on nor have i ever had any body ride in the middle seats., auto rain sensor wipers do not work, and FYI if all of the Wagoneer client service folks are like the one i have been dealing with forget about getting any straight answers or positive results from those dipsticks! I sure mis my Escalade and the awesome service that went with it. On a bright note i am first in-line for the new Escalade ESV
"V" series when they allow ordering around may 11th they tell me.
 
1 - 3 of 3 Posts
Top