Jeep Wagoneer Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hey

Has anyone had any issues with the rear A/C not blowing cold air?

It hasnt been very warm here in MI until this week, and today i tested the rear a/c and it doesnt blow cold air. Even the front doesnt feel that cold.
 

·
Registered
Joined
·
1 Posts
Did this issue ever get fixed, I just walked away from a series 3 because the entire ac was blowing warm air and it was 95 in Texas still not summer


Hey

Has anyone had any issues with the rear A/C not blowing cold air?

It hasnt been very warm here in MI until this week, and today i tested the rear a/c and it doesnt blow cold air. Even the front doesnt feel that cold.
 

·
Registered
Joined
·
1 Posts
I have the same experience. Front and rear air start weak when outside temp is cool. Stronger start when outside temp is warmer. My Wrangler behaves similarly. My conclusion is that, on both, the outside digital temp reading influences the systems sensing and how hard it starts. Frustrating when you come into a hot cab on a cool day. I agree with Texas Jester. Seems to be in the Chrysler truck DNA.
 

·
Registered
Joined
·
1 Posts
Same thing. Front AC blowing 56F, rear AC blowing 68F. Took to dealership and they said refrigerant levels were fine. The front AC control screen (same as Massage/etc) was showing dim and they ordered a part to fix, claiming that it may assist with getting colder air to the rear, I don't think it will help though....will see.
 
1 - 14 of 14 Posts
Top