Jeep Wagoneer Forum banner
1 - 11 of 11 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
The gps map will not load on the instrument cluster screen on my new Wagoneer. It says that the map is loading which it never does or it says it is temporarily unavailable.
 

·
Registered
Joined
·
9 Posts
Hello,

We're disheartened to learn about the concerns that you've been experiencing with your navigation, recently. If you're still in need of assistance, please do not hesitate to send our team a private message with your VIN and additional details. We'd be more than happy to help you get this properly addressed.

Thanks,

Courtney
Wagoneer Client Services
 

·
Registered
Joined
·
6 Posts
It started working again yesterday. Now if AT&T could get their stuff together so we can have WiFi we will be all set.
I was able to get it working by calling them on the phone. It was a very manual process and I’m pretty confident all my personal data has now been sold to the prince Antarctica but it does work now. Key point - they HAD to add the 1GB trial BEFORE I could purchase the 1 year plan.
 

·
Registered
Joined
·
55 Posts
I was able to get it working by calling them on the phone. It was a very manual process and I’m pretty confident all my personal data has now been sold to the prince Antarctica but it does work now. Key point - they HAD to add the 1GB trial BEFORE I could purchase the 1 year plan.
I ran into the same thing. ☹ I quickly blew through the 1GB and signed up for the annual plan. How did you figure out the hot spot phone number?
 

·
Registered
Joined
·
3 Posts
Hello,

We're disheartened to learn about the concerns that you've been experiencing with your navigation, recently. If you're still in need of assistance, please do not hesitate to send our team a private message with your VIN and additional details. We'd be more than happy to help you get this properly addressed.

Thanks,

Courtney
Wagoneer Client Services
I'm too new to forum and blocked from DMing but having same issue.

Driver instrument cluster rarely ever successfully loads the Map and is a great hindrance to usability and enjoyment of the vehicle. Map Display is Loading Please Wait

How can I soft rest the instrument cluster (rebooting main dash system does not restart cluster)?

Will that resolve it?
 

·
Registered
Joined
·
178 Posts
I'm too new to forum and blocked from DMing but having same issue.

Driver instrument cluster rarely ever successfully loads the Map and is a great hindrance to usability and enjoyment of the vehicle. Map Display is Loading Please Wait

How can I soft rest the instrument cluster (rebooting main dash system does not restart cluster)?

Will that resolve it?
Welcome to the forum @DBR1! How often does it happen? Does it reset if you turn the car on and off?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #10 ·
The entire UConnect system on the Wagoneer appears to be very glitchy. Sometimes the map loads, many times it doesn’t, WiFi has issues, rear entertainment screens power on and off on their own, and sometimes won’t connect even when WiFi is working. Wireless Car Play has been a real problem for us.
 

·
Registered
Joined
·
3 Posts
The entire UConnect system on the Wagoneer appears to be very glitchy. Sometimes the map loads, many times it doesn’t, WiFi has issues, rear entertainment screens power on and off on their own, and sometimes won’t connect even when WiFi is working. Wireless Car Play has been a real problem for us.
Same boat as you. Hopefully a software update will fix very soon. I'm accustomed to constant feature improvements and updates over the air from another manufacturer which is unfortunately unique to the industry. I have high hopes for Wagoneer here.
 
1 - 11 of 11 Posts
Top