Jeep Wagoneer Forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 · (Edited)
Jason from Michigan. Took delivery of my first ever Chrysler/Jeep vehicle last week. Wagoneer Series III. I posted some pics of it on the pics thread. Love my ride. I've already got two road trips under my belt in it. One of them was an 8 hour trip towing a sxs. Thing was a beast. Never blinked! The second was a 575 mile trip to Cleveland for work. The hemi avg 21.9mpg over that trip. Was thoroughly impressed! I traded up to this ride from a 2022 Aviator. Loved that car so much but it just wasn't big enough for our family. This thing isn't quite as much fun to drive but it's got everything I needed and does it in style!

I have already had to take the ride in for service. Which is a little concerning. The screen does this weird thing where it won't turn on unless I manually press the power button for the radio. Nothing works until I do that but the back up camera. Radio, climate, android auto, nadda. However when I pop the csr into reverse the back up camera turns on. Then when I put it back I drive, the screen goes dead again. They have to open some ticket with Chrysler to get that looked at by an engineer.

Anyhow. That's my story. Look forward to learning from yall. Is there a discord server??
 

·
Registered
Joined
·
56 Posts
Jason from Michigan. Took delivery of my first ever Chrysler/Jeep vehicle last week. Wagoneer Series III. I posted some pics of it on the pics thread. Love my ride. I've already got two road trips under my belt in it. One of them was an 8 hour trip towing a sxs. Thing was a beast. Never blinked! The second was a 575 mile trip to Cleveland for work. The hemi avg 21.9mpg over that trip. Was thoroughly impressed! I traded up to this ride from a 2022 Aviator. Loved that car so much but it just wasn't big enough for our family. This thing isn't quite as much fun to drive but it's got everything I needed and does it in style!

I have already had to take the ride in for service. Which is a little concerning. The screen does this weird thing where it won't turn on unless I manually press the power button for the radio. Nothing works until I do that but the back up camera. Radio, climate, android auto, nadda. However when I pop the csr into reverse the back up camera turns on. Then when I put it back I drive, the screen goes dead again. They have to open some ticket with Chrysler to get that looked at by an engineer.

Anyhow. That's my story. Look forward to learning from yall. Is there a discord server??
Our team would be happy to research any additional information on this and provide additional support to you. Feel welcome to send us a PM with your VIN for further assistance.

Steph
Wagoneer Client Services
 
1 - 2 of 2 Posts
Top