Jeep Wagoneer Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
Hello everyone.
I have a Grand Wagoneer Obsidian. For the most part, I absolutely love it. However, there are a few hiccups that I’ve run into over the past 4 weeks.
  • Car Play: Whenever I have a phone call or listen to music (e.g., Spotify) over CarPlay, there a constant repetitive whooshing sound over the speakers. It sounds like a fetal heartbeat ultrasound. Whoosh whoosh whoosh. This has to be my biggest complaint with the car. I’m an executive in the music industry and getting the Macintosh audio system was amazing for me. However, this has become my biggest nuisance with the car. Listening to new tracks, particularly with some clients on the road, has left me quite embarrassed and them laughing at this distortion. $105K+ car with a Macintosh system and you have this annoying background whoosh constantly going. Unacceptable.
  • Windshield: like many other customers have noted, there is definitely some sort of distortion/wave in the windshield towards the center. Very annoying. There needs to be a recall on this.
  • Seat Warmers: I’ve experienced the same quick auto turnoff of the seat warmers as other customers. Another thread noted that a fix is coming in January and to keep on Medium or Low. Ugh!
  • Relax Mode: Sometimes this mode doesn’t appear on the driver’s dash. Just the center and passenger screens. Not sure why. I contacted client services and they’ve been trying to figure out the issue for a few weeks now. I just got an email about setting up Diagnosis at a dealer. I’ll update when this gets resolved.
  • Navigation: When using the SUV’s navigation (TomTom?), it constantly crashed and reboots on its own. I’ve missed several exits because of untimely crash and reboots. Annoying!!
  • Passenger Screen: Has anyone else have issues with the passenger screen being ultra dim? I’ve changed it to the brightest setting but it’s still extremely dim. Not sure what’s going on here.

I’ll keep updating this list as time goes on. Please let me know your thoughtsand if you have similar issues.

Thanks.
 

·
Registered
Joined
·
10 Posts
Thank you for posting these! I am having all of these issues minus the navigation issue you had. I sure hope we get a software update that I can run at home
 

·
Registered
2022 Grand Wagoneer Series III
Joined
·
12 Posts
I have everyone of those issues with mine except the audio whooshing sound and I haven't used the nav yet. I use Tidal. Maybe that has something to do with it. I just picked my GWS3 yesterday however I did see an OTA update hit my vehicle today. I haven't been back in it since then. Hopefully this update will handle some of the minor issues.
 

·
Registered
Joined
·
1 Posts
Hello everyone.
I have a Grand Wagoneer Obsidian. For the most part, I absolutely love it. However, there are a few hiccups that I’ve run into over the past 4 weeks.
  • Car Play: Whenever I have a phone call or listen to music (e.g., Spotify) over CarPlay, there a constant repetitive whooshing sound over the speakers. It sounds like a fetal heartbeat ultrasound. Whoosh whoosh whoosh. This has to be my biggest complaint with the car. I’m an executive in the music industry and getting the Macintosh audio system was amazing for me. However, this has become my biggest nuisance with the car. Listening to new tracks, particularly with some clients on the road, has left me quite embarrassed and them laughing at this distortion. $105K+ car with a Macintosh system and you have this annoying background whoosh constantly going. Unacceptable.
  • Windshield: like many other customers have noted, there is definitely some sort of distortion/wave in the windshield towards the center. Very annoying. There needs to be a recall on this.
  • Seat Warmers: I’ve experienced the same quick auto turnoff of the seat warmers as other customers. Another thread noted that a fix is coming in January and to keep on Medium or Low. Ugh!
  • Relax Mode: Sometimes this mode doesn’t appear on the driver’s dash. Just the center and passenger screens. Not sure why. I contacted client services and they’ve been trying to figure out the issue for a few weeks now. I just got an email about setting up Diagnosis at a dealer. I’ll update when this gets resolved.
  • Navigation: When using the SUV’s navigation (TomTom?), it constantly crashed and reboots on its own. I’ve missed several exits because of untimely crash and reboots. Annoying!!
  • Passenger Screen: Has anyone else have issues with the passenger screen being ultra dim? I’ve changed it to the brightest setting but it’s still extremely dim. Not sure what’s going on here.

I’ll keep updating this list as time goes on. Please let me know your thoughtsand if you have similar issues.

Thanks.
Were you able to figure out the passenger screen too dim issue? Just got a WL74 and I have the same issue with my passenger screen.
 
1 - 4 of 4 Posts
Top