Jeep Wagoneer Forum banner
1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Has anyone had any issues with the main screen display going black, shutting off, red screen sweeping from left to right side and not working at all? Also buzzing in the speakers when this is on going? Now as of this morning my wife was on the way back from taking our kids to school and she said the drivers dash lit up with lights, "dingers" going off and 4X4 lights flashing and stabilitrak warning flashing, and locked up the emergency braking! After multiple restart attempts she was able to get it home and in the driveway the same thing happened. We contacted the dealership and we are getting it towed there to be checked out. The vehicle is only a few months old with about 3400 miles on it.
Has anyone had this happen, any of these issues? The main display has done this multiple times but this new issues is extremely alarming activating the emergency brake system while driving is something that I, nor she, is comfortable with. Any help is very much appreciated.
 

·
Registered
Joined
·
7 Posts
There is a recall on one of these issues that is causing problems. There is also an update for the software that shouild be available to you at the dealer. Hopefully this helps. Let us know if it gets fixed.
Computer Personal computer Font Gadget Software
 

·
Registered
Joined
·
1 Posts
Has anyone had any issues with the main screen display going black, shutting off, red screen sweeping from left to right side and not working at all? Also buzzing in the speakers when this is on going? Now as of this morning my wife was on the way back from taking our kids to school and she said the drivers dash lit up with lights, "dingers" going off and 4X4 lights flashing and stabilitrak warning flashing, and locked up the emergency braking! After multiple restart attempts she was able to get it home and in the driveway the same thing happened. We contacted the dealership and we are getting it towed there to be checked out. The vehicle is only a few months old with about 3400 miles on it.
Has anyone had this happen, any of these issues? The main display has done this multiple times but this new issues is extremely alarming activating the emergency brake system while driving is something that I, nor she, is comfortable with. Any help is very much appreciated.
Yes we have the 2022 wagoneer it's has less then 2000 miles on it been in the shop 3 times...ck engine light on...ans I have also has the same issue you described...they said it wa a wiring harness issue..
Currently we are having louver issues, which not sure about...something about the front side of the radiator....I had a tickin going on..and said something 😳 and they thought I was nuts and gave the excuse the car needed to warm up its normal 😉 🙄....well it's new on the market 😉 few bumps and bruises....
Good luck...
O
 

·
Registered
Joined
·
2 Posts
Has anyone had any issues with the main screen display going black, shutting off, red screen sweeping from left to right side and not working at all? Also buzzing in the speakers when this is on going? Now as of this morning my wife was on the way back from taking our kids to school and she said the drivers dash lit up with lights, "dingers" going off and 4X4 lights flashing and stabilitrak warning flashing, and locked up the emergency braking! After multiple restart attempts she was able to get it home and in the driveway the same thing happened. We contacted the dealership and we are getting it towed there to be checked out. The vehicle is only a few months old with about 3400 miles on it.
Has anyone had this happen, any of these issues? The main display has done this multiple times but this new issues is extremely alarming activating the emergency brake system while driving is something that I, nor she, is comfortable with. Any help is very much appreciated.
i have had the same experience, my rear axle fell off as all the warnings for AWD, Anti Lock Brakes, Power Steering were flasing
 

·
Registered
Joined
·
1 Posts
Has anyone had any issues with the main screen display going black, shutting off, red screen sweeping from left to right side and not working at all? Also buzzing in the speakers when this is on going? Now as of this morning my wife was on the way back from taking our kids to school and she said the drivers dash lit up with lights, "dingers" going off and 4X4 lights flashing and stabilitrak warning flashing, and locked up the emergency braking! After multiple restart attempts she was able to get it home and in the driveway the same thing happened. We contacted the dealership and we are getting it towed there to be checked out. The vehicle is only a few months old with about 3400 miles on it.
Has anyone had this happen, any of these issues? The main display has done this multiple times but this new issues is extremely alarming activating the emergency brake system while driving is something that I, nor she, is comfortable with. Any help is very much appreciated.
We are having the same issue!! There is clearly an electrical issue. Has anyone been successful in getting it fixed or do we have a lemon?
 

·
Registered
Joined
·
19 Posts
Day 3 and and our thermostat and fan speed physical buttons don’t seem to work at all. And the touchscreen is definitely buggy.
plan on having it picked up tomorrow or Wednesday to go in.
Hopefully this is all easily fixed with updates.
 

·
Registered
Joined
·
3 Posts
We've been having problems since the beginning limit 4,600 mi right now and currently Jeep is running with zero accessories I'm able to open up the sunroof but I have no radio no air conditioning no windows roll up and down seats don't move. Yesterday one time it started working correctly I know now immediately if I open up the doors and my steps don't fold down the vehicle is not operating properly. HELP!!!! No A/C
 

·
Registered
Joined
·
2 Posts
Has anyone had any issues with the main screen display going black, shutting off, red screen sweeping from left to right side and not working at all? Also buzzing in the speakers when this is on going? Now as of this morning my wife was on the way back from taking our kids to school and she said the drivers dash lit up with lights, "dingers" going off and 4X4 lights flashing and stabilitrak warning flashing, and locked up the emergency braking! After multiple restart attempts she was able to get it home and in the driveway the same thing happened. We contacted the dealership and we are getting it towed there to be checked out. The vehicle is only a few months old with about 3400 miles on it.
Has anyone had this happen, any of these issues? The main display has done this multiple times but this new issues is extremely alarming activating the emergency brake system while driving is something that I, nor she, is comfortable with. Any help is very much appreciated.
Yes
 
1 - 10 of 10 Posts
Top