Jeep Wagoneer Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
So my battery has died 3 times now. The dealership can’t find anything wrong with it. They ran a bunch of tests and what not. Most recently, they said if it happens again, don’t have it jumped- just have it towed in.
I see other people have had an amp issue draining the battery. How was it resolved?
 

·
Registered
Joined
·
22 Posts
There’s a customer satisfaction recall for this because of amplifier battery drain. Have you had that recall done?

It is a software update. My dealer came out to the house and got the Jeep, took it in and did the update and dropped it back off. We worked the details through Wagoneer client services when it wouldn’t start one morning.

We haven’t had an issue since.
 

·
Registered
Joined
·
18 Posts
So my battery has died 3 times now. The dealership can’t find anything wrong with it. They ran a bunch of tests and what not. Most recently, they said if it happens again, don’t have it jumped- just have it towed in.
I see other people have had an amp issue draining the battery. How was it resolved?
Read my posts on several links here. Mine has been towed 6 times, all they can tell me is there will be a large reprogramming in the 4th qtr. so i guess park it in a corner until maybe oct at the earliest. i dont even drive mine anymore, tired of having to jumpstart it, fyi they did the amp fix,and actually had central region head tech blank all the pcs in my truck and reload, it didnt last for even 2 days and it went dead again, Jeep says to bad for me and the dealer says the same!!!!! Mine is a GWIII. I own over a dozen Jeep and Ram vehicles in my company fleet, i guess this is their thank You to Me!
 

·
Registered
Joined
·
1 Posts
So my battery has died 3 times now. The dealership can’t find anything wrong with it. They ran a bunch of tests and what not. Most recently, they said if it happens again, don’t have it jumped- just have it towed in.
I see other people have had an amp issue draining the battery. How was it resolved?
Hey - did they get resolved? Going thru the same… dealership cant find anything… 2-3 weeks later battery dead again
 

·
Registered
Joined
·
2 Posts
What year is it? I went through something similar back then but ironically it was the battery that couldn't retain charge anymore. If you really need your vehicle and don't want to be stuck somewhere randomly I'd unhook the battery whenever you turn off the engine.
 

·
Registered
2022 Grand Wagoneer Obsidian
Joined
·
2 Posts
Hey - did they get resolved? Going thru the same… dealership cant find anything… 2-3 weeks later battery dead again
Edgard, my GW's battery died twice within a one-day timespan two days after I took delivery. After the service department had my vehicle for over two weeks, they were finally able to determine that there was an "issue" (see the embedded pictures below) with the lift gate wiring (Mopar part number 68447728AD). Since this part was replaced, I haven't had any issues (6 days and counting) regarding the battery draining. I am not sure if this is the same issue your vehicle is having, but I wanted to share my experience just in case.


View attachment 1477 View attachment 1478
 
1 - 6 of 6 Posts
Top